profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / Class-Data-Accessor / Class-Data-Accessor-0.40.40-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=CLACO
7 DIST_VERSION=0.04004
8 inherit perl-module
9
10 DESCRIPTION="Inheritable, overridable class and instance data accessor creation"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16 PATCHES=( "${FILESDIR}/${PN}-0.04004-no-dot-inc.patch" )
17
18 RDEPEND="virtual/perl-Carp"
19 DEPEND="${RDEPEND}
20         virtual/perl-ExtUtils-MakeMaker
21         test? ( virtual/perl-Test-Simple )
22 "
23 PERL_RM_FILES=(
24         t/manifest.t
25         t/pod_coverage.t
26         t/pod_spelling.t
27         t/pod_syntax.t
28         t/strict.t
29         t/style_no_tabs.t
30         t/warnings.t
31 )