dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Class-Adapter / Class-Adapter-1.80.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=ADAMK
7 MODULE_VERSION=1.08
8 inherit perl-module
9
10 DESCRIPTION='Implementation of the "Adapter" Design Pattern'
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=virtual/perl-Scalar-List-Utils-1.10"
19 DEPEND="${RDEPEND}
20         test? ( virtual/perl-Test-Simple )"
21
22 SRC_TEST=do
23
24 src_prepare() {
25         sed -i -e 's/use inc::Module::Install::DSL /use lib q[.];\nuse inc::Module::Install::DSL /' Makefile.PL ||
26                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
27         perl-module_src_prepare
28 }