sys-kernel/gentoo-sources: Linux patch 4.9.170
[gentoo.git] / dev-perl / Cairo / Cairo-1.106.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=XAOC
7 MODULE_VERSION=1.106
8 inherit perl-module
9
10 DESCRIPTION="Perl interface to the cairo library"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16
17 RDEPEND="
18         >=x11-libs/cairo-1.0.0
19 "
20 DEPEND="${RDEPEND}
21         virtual/perl-ExtUtils-MakeMaker
22         >=dev-perl/ExtUtils-Depends-0.200.0
23         >=dev-perl/ExtUtils-PkgConfig-1.0.0
24         test? (
25                 dev-perl/Test-Number-Delta
26         )
27 "
28
29 SRC_TEST="do"
30
31 src_prepare() {
32         perl-module_src_prepare
33         sed -i -e 's,exit 0,exit 1,' "${S}"/Makefile.PL || die
34 }