dev-libs/tomsfastmath: keyworded 0.13.1 for ia64, bug #725414
[gentoo.git] / dev-perl / Cache-Memcached / Cache-Memcached-1.300.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=DORMANDO
7 DIST_VERSION=1.30
8 inherit perl-module
9
10 DESCRIPTION="Perl API for memcached"
11 HOMEPAGE="http://www.danga.com/memcached/ https://metacpan.org/release/Cache-Memcached"
12 # Bug: https://bugs.gentoo.org/721730
13 LICENSE="|| ( Artistic GPL-1 )"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
16
17 RDEPEND="
18         virtual/perl-Encode
19         virtual/perl-Storable
20         dev-perl/String-CRC32
21         virtual/perl-Time-HiRes
22 "
23 BDEPEND="${RDEPEND}
24         virtual/perl-ExtUtils-MakeMaker
25 "
26 src_test() {
27         ewarn "Comprehensive testing of this module needs manual configuration."
28         ewarn "For details, see:"
29         ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
30         echo
31         perl-module_src_test
32 }