dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / CGI-Simple / CGI-Simple-1.115.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=SZABGAB
7 MODULE_VERSION=1.115
8 inherit perl-module
9
10 DESCRIPTION="A Simple totally OO CGI interface that is CGI.pm compliant"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="dev-perl/Module-Build
19         test? (
20                 dev-perl/libwww-perl
21                 dev-perl/IO-stringy
22         )
23 "
24
25 SRC_TEST="do"
26
27 src_test() {
28         perl_rm_files t/pod.t t/manifest.t t/pod-coverage.t
29         perl-module_src_test
30 }