30159a9c80d85a41206afbfda19bf83b84ef0eab
[gentoo.git] / dev-perl / Business-ISSN / Business-ISSN-1.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=BDFOY
7 DIST_VERSION=1.003
8 inherit perl-module
9
10 DESCRIPTION="Object and functions to work with International Standard Serial Numbers"
11 LICENSE="Artistic-2"
12
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         virtual/perl-Exporter
20 "
21 DEPEND="${RDEPEND}
22         >=virtual/perl-ExtUtils-MakeMaker-6.640.0
23         virtual/perl-File-Spec
24         test? ( virtual/perl-Test-Simple )
25 "
26 PERL_RM_FILES=(
27         "t/pod.t"
28         "t/pod_coverage.t"
29         "t/test_manifest"
30 )
31 PATCHES=(
32         "${FILESDIR}/${PN}-1.003-no-test-manifest.patch"
33 )