c04053955cb033b3cdd49801fdc42194264c36fe
[gentoo.git] / dev-perl / B-Hooks-EndOfScope / B-Hooks-EndOfScope-0.240.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ETHER
7 DIST_VERSION=0.24
8 inherit perl-module
9
10 DESCRIPTION="Execute code after a scope finished compilation"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15
16 RDEPEND="
17         >=dev-perl/Module-Implementation-0.50.0
18         virtual/perl-Scalar-List-Utils
19         >=dev-perl/Sub-Exporter-Progressive-0.1.6
20         >=dev-perl/Variable-Magic-0.480.0
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         virtual/perl-Text-ParseWords
25         test? (
26                 >=virtual/perl-CPAN-Meta-2.120.900
27                 virtual/perl-File-Spec
28                 >=virtual/perl-Test-Simple-0.880.0
29         )
30 "