profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / Authen-NTLM / Authen-NTLM-1.90.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MY_PN=NTLM
7 MODULE_AUTHOR=NBEBOUT
8 MODULE_VERSION=1.09
9 inherit perl-module
10
11 DESCRIPTION="An NTLM authentication module"
12
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND=">=virtual/perl-MIME-Base64-3.00
19         dev-perl/Digest-HMAC"
20 DEPEND="${RDEPEND}
21         test? ( virtual/perl-Test-Simple )
22 "
23
24 SRC_TEST=do
25 export OPTIMIZE="$CFLAGS"
26
27 src_test() {
28         perl_rm_files t/99_pod.t
29         perl-module_src_test
30 }