dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / dev-perl / Archive-Zip / Archive-Zip-1.680.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=PHRED
7 DIST_VERSION=1.68
8 DIST_EXAMPLES=("examples/*")
9 inherit perl-module
10
11 DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
12
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=virtual/perl-Compress-Raw-Zlib-2.17.0
20         virtual/perl-Encode
21         virtual/perl-File-Path
22         >=virtual/perl-File-Spec-0.800.0
23         virtual/perl-File-Temp
24         virtual/perl-IO
25         virtual/perl-Time-Local
26 "
27 BDEPEND="${RDEPEND}
28         virtual/perl-ExtUtils-MakeMaker
29         test? (
30                 app-arch/unzip
31                 >=virtual/perl-Test-Simple-0.880.0
32         )
33 "