profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / Apache-LogFormat-Compiler / Apache-LogFormat-Compiler-0.350.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=KAZEBURO
7 DIST_VERSION=0.35
8 DIST_EXAMPLES=("eg/*")
9 inherit perl-module
10
11 DESCRIPTION="Compile an Apache log format string to perl-code"
12
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 # POSIX -> perl
19 RDEPEND="
20         >=dev-perl/POSIX-strftime-Compiler-0.300.0
21         virtual/perl-Time-Local
22         >=dev-lang/perl-5.8.4"
23
24 # HTTP::Request::Common -> HTTP-Message
25 # Test::More -> perl-Test-Simple
26 # URI::Escape -> URI
27 DEPEND="${RDEPEND}
28                 >=dev-perl/Module-Build-Tiny-0.35.0
29                 test? (
30                                 dev-perl/HTTP-Message
31                                 dev-perl/Test-MockTime
32                                 >=virtual/perl-Test-Simple-0.980.0
33                                 dev-perl/Test-Requires
34                                 >=dev-perl/Try-Tiny-0.120.0
35                                 >=dev-perl/URI-1.600.0
36                 )
37 "