dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / AnyEvent-CacheDNS / AnyEvent-CacheDNS-0.80.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=POTYL
7 DIST_VERSION=0.08
8 inherit perl-module
9
10 DESCRIPTION="Simple DNS resolver with caching"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 # License note: says 'perl 5.8.8 or any later' bug #718946
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-perl/AnyEvent
20 "
21 DEPEND="${RDEPEND}
22         virtual/perl-File-Spec
23         >=dev-perl/Module-Build-0.400.0
24         test? ( virtual/perl-Test-Simple )
25 "
26 src_test() {
27         local my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
28         if has network ${my_test_control}; then
29                 perl-module_src_test
30         else
31                 einfo "Tests skipped without DIST_TEST_OVERRIDE =~ network: Fails under network sandboxing"
32         fi
33 }