dev-perl/*: Update Manifest hashes
[gentoo.git] / dev-perl / Alien-wxWidgets / Alien-wxWidgets-0.680.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 WX_GTK_VER=3.0
7 DIST_AUTHOR=MDOOTSON
8 DIST_VERSION=0.68
9 inherit wxwidgets perl-module
10
11 DESCRIPTION="Building, finding and using wxWidgets binaries"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~ia64 ~x86"
15 IUSE="gstreamer opengl test"
16
17 RDEPEND="
18         >=x11-libs/wxGTK-3:3.0[gstreamer=,opengl=,tiff,X]
19         >=dev-perl/Module-Pluggable-2.600.0
20 "
21 DEPEND="${RDEPEND}
22         >=virtual/perl-ExtUtils-CBuilder-0.24
23         >=virtual/perl-File-Spec-1.500.0
24         >=dev-perl/Module-Build-0.280.0
25         test? ( virtual/perl-Test-Simple )
26 "
27
28 src_configure() {
29         myconf=( --wxWidgets-build=0 )
30         perl-module_src_configure
31 }
32
33 src_test() {
34         perl_rm_files t/zz_pod.t t/zy_pod_coverage.t
35         perl-module_src_test
36 }