dev-ml/num: use ocamlopt
[gentoo.git] / dev-ml / tyxml / tyxml-4.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_DOCS=1
7 # Cannot find findlib package alcotest
8 # OASIS_BUILD_TESTS=1
9
10 inherit oasis
11
12 DESCRIPTION="A libary to build xml trees typechecked by OCaml"
13 HOMEPAGE="http://ocsigen.org/tyxml/"
14 SRC_URI="https://github.com/ocsigen/tyxml/archive/${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="LGPL-2.1-with-linking-exception"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64"
19 IUSE="+ppx +camlp4"
20
21 DEPEND="
22         >=dev-ml/uutf-1.0:=
23         dev-ml/uchar:=
24         dev-ml/ocaml-re:=
25         ppx? ( >=dev-ml/ppx_tools-5:= dev-ml/markup:= )
26         camlp4? ( dev-ml/camlp4:= )"
27 RDEPEND="${DEPEND}"
28
29 DOCS=( CHANGES README.md )
30
31 src_configure() {
32         oasis_configure_opts="
33                 $(use_enable camlp4 syntax)
34                 $(use_enable ppx)
35         " oasis_src_configure
36 }