dev-ml/lablgtk: uses CFLAGS and fix -fno-common
[gentoo.git] / dev-ml / type-conv / type-conv-113.00.02.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 OASIS_BUILD_DOCS=1
7
8 inherit oasis
9
10 MY_P=${PN/-/_}-${PV}
11 DESCRIPTION="Mini library required for some other preprocessing libraries"
12 HOMEPAGE="http://janestreet.github.io/"
13 SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
14
15 LICENSE="LGPL-2.1-with-linking-exception"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~ppc ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-lang/ocaml-4.02[ocamlopt?]
21         dev-ml/camlp4:="
22 DEPEND="${RDEPEND}
23         >=dev-ml/findlib-1.3.2"
24
25 DOCS=( "README.md" "CHANGES.md" )
26
27 S="${WORKDIR}/${MY_P}"