3a5b9b4aa827e1c133255cafffe7a1e4f8150ae7
[gentoo.git] / dev-ml / seq / seq-0.1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Compatibility package for the standard OCaml iterator type"
7 HOMEPAGE="https://github.com/c-cube/seq"
8 SRC_URI="https://github.com/c-cube/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND="dev-ml/ocamlbuild"
16 RDEPEND="${DEPEND}"
17 BDEPEND=""
18
19 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
20
21 src_prepare() {
22         default
23         sed -i \
24                 -e "s:@LIBDIR@:/usr/$(get_libdir)/ocaml:" \
25                 Makefile \
26                 || die
27 }
28
29 src_install() {
30         dodir /usr/$(get_libdir)/ocaml
31         default
32 }