dev-ml/seq: fix dependency
[gentoo.git] / dev-ml / seq / seq-0.1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Compatibility package for the standard OCaml iterator type"
7 HOMEPAGE="https://github.com/c-cube/seq"
8 SRC_URI="https://github.com/c-cube/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND="dev-ml/findlib
16         dev-ml/ocamlbuild"
17 RDEPEND="${DEPEND}"
18 BDEPEND=""
19
20 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
21
22 src_prepare() {
23         default
24         sed -i \
25                 -e "s:@LIBDIR@:/usr/$(get_libdir)/ocaml:" \
26                 Makefile \
27                 || die
28 }
29
30 src_install() {
31         dodir /usr/$(get_libdir)/ocaml
32         default
33 }