dev-ml/seq: RedundantLongDescription
[gentoo.git] / dev-ml / rresult / rresult-0.5.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="Result value combinators for OCaml"
9 HOMEPAGE="http://erratique.ch/software/rresult https://github.com/dbuenzli/rresult"
10 SRC_URI="http://erratique.ch/software/rresult/releases/${P}.tbz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 RDEPEND="dev-ml/result:="
18 DEPEND="${RDEPEND}
19         dev-ml/topkg
20         dev-ml/ocamlbuild"
21
22 src_compile() {
23         ocaml pkg/pkg.ml build || die
24 }