dev-ml/camlpdf: remove old
[gentoo.git] / dev-ml / result / result-1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit findlib
7
8 DESCRIPTION="Compat result type"
9 HOMEPAGE="https://github.com/janestreet/result"
10 SRC_URI="https://github.com/janestreet/result/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
15 IUSE="+ocamlopt"
16
17 RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
18 DEPEND="${RDEPEND}"
19
20 src_compile() {
21         emake byte
22         use ocamlopt && emake native
23 }
24
25 src_install() {
26         findlib_src_install
27         dodoc README.md
28 }