dev-ml/camlp5: ppc stable wrt bug #709348
[gentoo.git] / dev-ml / react / react-1.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit opam
7
8 DESCRIPTION="OCaml module for functional reactive programming"
9 HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
10 SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~ppc ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND=""
19 DEPEND="${RDEPEND}
20         dev-ml/findlib
21         >=dev-ml/topkg-0.9
22 "
23
24 src_compile() {
25         ocaml pkg/pkg.ml build \
26                 --tests $(usex test 'true' 'false') \
27                 || die
28 }
29
30 src_test() {
31         ocaml pkg/pkg.ml test || die
32 }