Merge the GLEP 67 transition changes
[gentoo.git] / dev-ml / qcheck / qcheck-0.4.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 OASIS_BUILD_DOCS=1
7
8 inherit oasis
9
10 DESCRIPTION="QuickCheck inspired property-based testing for OCaml"
11 HOMEPAGE="https://github.com/c-cube/qcheck"
12 SRC_URI="https://github.com/c-cube/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="+ounit"
18
19 RDEPEND="
20         ounit? ( >=dev-ml/ounit-2:= )
21 "
22 DEPEND="
23         ${RDEPEND}
24 "
25
26 src_configure() {
27         oasis_configure_opts="
28                 $(use_enable ounit)
29         " oasis_src_configure
30 }
31
32 DOCS=( CHANGELOG.md README.md )