dev-ml/llvm-ocaml: Remove broken VE target from 10.0.0rc2
[gentoo.git] / dev-ml / ppx_tools / ppx_tools-5.3.4.08.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit findlib eutils
7
8 MY_PV=$(ver_rs 2 '+')
9 DESCRIPTION="Tools for authors of ppx rewriters"
10 HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
11 SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0/${PV}"
15 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
16 IUSE="+ocamlopt"
17
18 DEPEND="dev-lang/ocaml:=[ocamlopt?]"
19 RDEPEND="${DEPEND}"
20 S="${WORKDIR}/${PN}-$(ver_rs 2 '-')"
21
22 src_compile() {
23         emake -j1 $(usex ocamlopt "" "ARCH=none")
24 }
25
26 src_install() {
27         findlib_src_install
28         dodoc README.md
29 }