dev-ml/llvm-ocaml: AVR is now mainline target
[gentoo.git] / dev-ml / ppx_sexp_conv / ppx_sexp_conv-0.9.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="Support Library for type-driven code generators"
9 HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
10 SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 DEPEND="
18         dev-ml/ppx_core:=
19         dev-ml/ppx_driver:=
20         dev-ml/ppx_type_conv:=
21         dev-ml/ppx_metaquot:=
22         dev-ml/ppx_optcomp:=
23         dev-ml/sexplib:=
24         dev-ml/ocaml-migrate-parsetree:=
25         dev-ml/ppx_traverse_builtins:=
26         "
27 RDEPEND="${DEPEND}"
28 DEPEND="${DEPEND} dev-ml/jbuilder"