dev-ml/camlp5: restricted 7.10 wrt ocaml
[gentoo.git] / dev-ml / ppx_metaquot / ppx_metaquot-0.9.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="Write OCaml AST fragment using OCaml syntax"
9 HOMEPAGE="https://github.com/janestreet/ppx_metaquot"
10 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 DEPEND="
18         dev-ml/ppx_core:=
19         dev-ml/ppx_driver:=
20         dev-ml/ppx_traverse_builtins:=
21         dev-ml/ocaml-migrate-parsetree:=
22         <dev-ml/ppx_core-100
23         "
24 RDEPEND="${DEPEND}"
25 DEPEND="${DEPEND} dev-ml/jbuilder"