Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-ml / ppx_jane / ppx_jane-113.33.00.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit oasis
7
8 DESCRIPTION="Standard Jane Street ppx rewriters"
9 HOMEPAGE="http://www.janestreet.com/ocaml"
10 SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 DEPEND="dev-ml/ppx_tools:=
18         dev-ml/ppx_assert:=
19         dev-ml/ppx_bench:=
20         dev-ml/ppx_bin_prot:=
21         dev-ml/ppx_compare:=
22         dev-ml/ppx_custom_printf:=
23         dev-ml/ppx_driver:=
24         dev-ml/ppx_enumerate:=
25         dev-ml/ppx_expect:=
26         dev-ml/ppx_fail:=
27         dev-ml/ppx_fields_conv:=
28         dev-ml/ppx_here:=
29         dev-ml/ppx_inline_test:=
30         dev-ml/ppx_let:=
31         dev-ml/ppx_pipebang:=
32         dev-ml/ppx_sexp_conv:=
33         dev-ml/ppx_sexp_message:=
34         dev-ml/ppx_sexp_value:=
35         dev-ml/ppx_typerep_conv:=
36         dev-ml/ppx_variants_conv:=
37 "
38 RDEPEND="${DEPEND}"
39 DEPEND="${DEPEND} dev-ml/opam"
40
41 src_configure() {
42         emake setup.exe
43         OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
44 }
45
46 src_compile() {
47         emake
48 }
49
50 src_install() {
51         opam-installer -i \
52                 --prefix="${ED}/usr" \
53                 --libdir="${D}/$(ocamlc -where)" \
54                 --docdir="${ED}/usr/share/doc/${PF}" \
55                 ${PN}.install || die
56         dodoc README.md
57 }