dev-ml/dune: arm stable wrt bug #710374
[gentoo.git] / dev-ml / ppx_base / ppx_base-0.9.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit opam
7
8 DESCRIPTION="Base set of ppx rewriters"
9 HOMEPAGE="https://github.com/janestreet/ppx_base"
10 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 DEPEND="
18         dev-ml/ppx_compare:=
19         dev-ml/ppx_driver:=
20         dev-ml/ppx_enumerate:=
21         dev-ml/ppx_hash:=
22         dev-ml/ppx_js_style:=
23         dev-ml/ppx_sexp_conv:=
24         dev-ml/ppx_type_conv:=
25         dev-ml/ocaml-migrate-parsetree:=
26         "
27 RDEPEND="${DEPEND}"
28 DEPEND="${DEPEND} dev-ml/jbuilder"