dev-ml/pomap: bump to 3.0.6
[gentoo.git] / dev-ml / pomap / pomap-3.0.6.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 DESCRIPTION="Partially Ordered Map ADT for O'Caml"
12 HOMEPAGE="http://mmottl.github.io/pomap/"
13 SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
14 LICENSE="LGPL-2.1-with-linking-exception"
15
16 DEPEND="dev-ml/camlp4:="
17 RDEPEND="${DEPEND}"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64 ~ppc ~x86"
20 IUSE="examples"
21
22 DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
23
24 src_install() {
25         oasis_src_install
26         if use examples ; then
27                 insinto /usr/share/doc/${PF}
28                 doins -r examples
29                 docompress -x /usr/share/doc/${PF}/examples
30         fi
31 }