dev-ml/pcre-ocaml: bump to 7.2.3
[gentoo.git] / dev-ml / pcre-ocaml / pcre-ocaml-7.2.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
12 HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
13 SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
14 LICENSE="LGPL-2.1-with-linking-exception"
15 IUSE="examples"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
18
19 RDEPEND=">=dev-libs/libpcre-4.5
20         >=dev-lang/ocaml-4:="
21 DEPEND="${RDEPEND}"
22
23 DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
24
25 src_install() {
26         oasis_src_install
27         if use examples ; then
28                 insinto /usr/share/doc/${PF}
29                 doins -r examples
30         fi
31 }