dev-ml/llvm-ocaml: Bump to 9.0.1 final
[gentoo.git] / dev-ml / opam-file-format / opam-file-format-2.0.0_beta3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit findlib
7
8 MY_PV="${PV/_beta/-beta}"
9 S="${WORKDIR}/${PN}-${MY_PV}"
10
11 DESCRIPTION="Parser and printer for the opam file syntax"
12 HOMEPAGE="https://github.com/ocaml/opam-file-format"
13 SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="+ocamlopt"
19
20 DEPEND="dev-lang/ocaml:=[ocamlopt?]"
21 RDEPEND="${DEPEND}"
22
23 src_compile() {
24         emake byte $(usex ocamlopt native "")
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
29 }