Merge the GLEP 67 transition changes
[gentoo.git] / dev-ml / opam / opam-1.2.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="A source-based package manager for OCaml"
10 HOMEPAGE="http://opam.ocaml.org/"
11 LICENSE="LGPL-3-with-linking-exception"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 if [[ ${PV} != 9999 ]]; then
17         SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
18 else
19         inherit git-r3
20         EGIT_REPO_URI="https://github.com/ocaml/opam.git"
21 fi
22
23 DEPEND="dev-lang/ocaml:=
24         || ( net-misc/wget net-misc/curl )
25         dev-ml/extlib:=
26         dev-ml/ocaml-re:=
27         dev-ml/ocamlgraph:=
28         dev-ml/cmdliner:=
29         dev-ml/cudf:=
30         >=dev-ml/dose3-4:=
31         dev-ml/uutf:=
32         dev-ml/jsonm:=
33 "
34 RDEPEND="${DEPEND}
35         dev-ml/findlib
36 "
37
38 src_prepare() {
39         epatch "${FILESDIR}/0001-Port-to-Dose3-4.0.1.patch"
40 }
41
42 src_compile() {
43         emake -j1
44         cd doc
45         emake man
46 }
47
48 src_test() {
49         EMAIL=foo@bar.com emake -j1 tests
50 }
51
52 src_install() {
53         default
54         emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
55 }