dev-ml/dune: arm stable wrt bug #710374
[gentoo.git] / dev-ml / ocurl / ocurl-0.7.9.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="OCaml interface to the libcurl library"
9 HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
10 LICENSE="MIT"
11 SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 SLOT="0/${PV}"
14 IUSE="examples"
15
16 RDEPEND=">=net-misc/curl-7.9.8
17         dev-ml/lwt:=
18         dev-ml/camlp4:=
19         >=dev-lang/ocaml-3.12:=[ocamlopt]"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22 KEYWORDS="~amd64 ~arm ~ppc ~x86"
23
24 src_compile()
25 {
26         emake -j1 all
27 }
28
29 src_install()
30 {
31         findlib_src_install
32         dodoc CHANGES.txt README.md
33         if use examples; then
34                 dodoc -r examples
35                 docompress -x /usr/share/doc/${PF}/examples
36         fi
37 }