dev-ml/dune: arm stable wrt bug #710374
[gentoo.git] / dev-ml / ocurl / ocurl-0.6.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="OCaml interface to the libcurl library"
9 HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/"
10 LICENSE="MIT"
11 SRC_URI="https://forge.ocamlcore.org/frs/download.php/1374/${P}.tgz"
12
13 SLOT="0/${PV}"
14 IUSE="examples"
15
16 RDEPEND=">=net-misc/curl-7.9.8
17                 >=dev-lang/ocaml-3.12:=[ocamlopt]"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20 KEYWORDS="amd64 ppc ~x86"
21
22 src_compile()
23 {
24         emake -j1 all
25 }
26
27 src_install()
28 {
29         findlib_src_install
30         dodoc CHANGES.txt README
31         if use examples; then
32                 dodoc -r examples
33                 docompress -x /usr/share/doc/${PF}/examples
34         fi
35 }