dev-qt/qdbus: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ml / ocamlweb / ocamlweb-1.39.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit latex-package
7
8 DESCRIPTION="O'Caml literate programming tool"
9 HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
10 SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 ppc x86"
15
16 DEPEND=">=dev-lang/ocaml-3.09:=
17         virtual/latex-base
18         dev-texlive/texlive-latexextra
19         "
20
21 PATCHES=(
22         "${FILESDIR}/${PN}-1.37-strip.patch"
23         )
24
25 src_compile() {
26         emake
27 }
28
29 src_install() {
30         emake UPDATETEX="" prefix="${D}/usr" MANDIR="${D}/usr/share/man" BASETEXDIR="${D}/${TEXMF}" install
31         dodoc README CHANGES
32 }