dev-ml/lablgtk: ppc stable wrt bug #586916
[gentoo.git] / dev-ml / ocamldap / ocamldap-2.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit oasis
8
9 DESCRIPTION="an implementation of the Light Weight Directory Access Protocol"
10 HOMEPAGE="http://git-jpdeplaix.dyndns.org/libs/ocamldap.git/"
11 SRC_URI="https://bitbucket.org/deplai_j/${PN}/downloads/${P}.tar.gz"
12 LICENSE="LGPL-2.1"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="doc"
16
17 DEPEND="dev-ml/pcre-ocaml:=
18         dev-ml/ocaml-ssl:=
19         dev-ml/ocamlnet:="
20 RDEPEND="${DEPEND}"
21
22 DOCS=( AUTHORS.txt Changelog INSTALL.txt README.txt )
23
24 PATCHES=( "${FILESDIR}/ocaml-4.02.patch" )
25
26 src_install() {
27         oasis_src_install
28         use doc && dohtml -r doc/ocamldap/html
29 }