Merge remote-tracking branch 'github/pr/795'.
[gentoo.git] / dev-ml / ocaml-uri / ocaml-uri-1.9.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="RFC3986 URI parsing library for OCaml"
12 HOMEPAGE="https://github.com/mirage/ocaml-uri https://mirage.io"
13 SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="ISC"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64"
18 IUSE="allservices"
19
20 RDEPEND="
21         dev-ml/ocaml-re:=
22         >=dev-ml/sexplib-109.53.00:=
23         <dev-ml/sexplib-113.01.00
24         dev-ml/stringext:=
25         dev-ml/type-conv:=
26 "
27 DEPEND="
28         test? ( >=dev-ml/ounit-1.0.2 )
29         ${RDEPEND}
30 "
31
32 src_configure() {
33         oasis_configure_opts="
34                 $(use_enable allservices)
35         " oasis_src_configure
36 }
37
38 DOCS=( CHANGES README.md )