*/*: Bump copyright on files touched this year
[gentoo.git] / dev-ml / ocaml-ssl / ocaml-ssl-0.5.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils
7
8 IUSE="doc"
9
10 DESCRIPTION="OCaml bindings for OpenSSL"
11 SRC_URI="https://github.com/savonet/ocaml-ssl/releases/download/${PV}/${P}.tar.gz"
12 HOMEPAGE="https://github.com/savonet/ocaml-ssl"
13
14 DEPEND="dev-libs/openssl:0=
15         >=dev-lang/ocaml-3.10:="
16 RDEPEND="${DEPEND}"
17
18 SLOT="0/${PV}"
19 LICENSE="LGPL-2.1"
20 KEYWORDS="~amd64 ~arm ~ppc ~x86"
21
22 src_compile() {
23         emake -j1
24 }
25
26 src_install() {
27         findlib_src_preinst
28         emake install
29
30         if use doc; then
31                 dohtml -r doc/html/*
32         fi
33         dodoc CHANGES README.md
34 }