Use https by default
[gentoo.git] / dev-ml / ocaml-ssl / ocaml-ssl-0.4.7.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit findlib eutils
8
9 IUSE="doc"
10
11 DESCRIPTION="OCaml bindings for OpenSSL"
12 SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
13 HOMEPAGE="http://savonet.sourceforge.net"
14
15 DEPEND="dev-libs/openssl[-bindist]
16         >=dev-lang/ocaml-3.10:="
17 RDEPEND="${DEPEND}"
18
19 SLOT="0/${PV}"
20 LICENSE="LGPL-2.1"
21 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
22
23 src_compile() {
24         emake -j1
25 }
26
27 src_install() {
28         findlib_src_preinst
29         emake install
30
31         if use doc; then
32                 dohtml -r doc/html/*
33         fi
34         dodoc CHANGES README
35 }