dev-ml/findlib: bump to 1.8.1
[gentoo.git] / dev-ml / ocaml-sqlite3 / ocaml-sqlite3-4.3.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit opam
7
8 MY_PN="sqlite3"
9 MY_P="${MY_PN}-${PV}"
10
11 DESCRIPTION="A package for ocaml that provides access to SQLite databases"
12 HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
13 SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/${PV}/${MY_P}.tbz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~ppc ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-db/sqlite-3.3.3"
21 DEPEND="${RDEPEND}
22         dev-ml/jbuilder
23         dev-ml/base
24         dev-ml/stdio
25         dev-ml/configurator
26         >=dev-ml/findlib-1.3.2"
27
28 S=${WORKDIR}/${MY_P}
29
30 src_compile() {
31         jbuilder build @install || die
32 }
33
34 src_install() {
35         opam_src_install "${MY_PN}"
36 }