dev-ml/findlib: bump to 1.8.1
[gentoo.git] / dev-ml / ocaml-sqlite3 / ocaml-sqlite3-4.1.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 MY_PN="sqlite3-ocaml"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="A package for ocaml that provides access to SQLite databases"
15 HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
16 SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/v${PV}/${MY_P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0/${PV}"
20 KEYWORDS="~amd64 ~ppc ~x86"
21 IUSE=""
22
23 DEPEND=">=dev-db/sqlite-3.3.3
24         >=dev-ml/findlib-1.3.2"
25 RDEPEND="${DEPEND}"
26
27 S=${WORKDIR}/${MY_P}
28 DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" "TODO.md" )