dev-ml/lablgtk: remove old 2.18.8-r0
[gentoo.git] / dev-ml / ocaml-re / ocaml-re-1.7.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="Regular expression library for OCaml"
12 HOMEPAGE="https://github.com/ocaml/ocaml-re"
13 SRC_URI="https://github.com/ocaml/ocaml-re/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="LGPL-2-with-linking-exception"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND=">=dev-lang/ocaml-4.02:="
22 DEPEND="${RDEPEND}
23         test? ( dev-ml/ounit )"
24 DOCS=( "CHANGES" "TODO.txt" "README.md" )