dev-ml/seq: RedundantLongDescription
[gentoo.git] / dev-ml / ocaml-magic-mime / ocaml-magic-mime-1.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Convert file extensions to MIME types"
7 HOMEPAGE="https://github.com/mirage/ocaml-magic-mime"
8 SRC_URI="https://github.com/mirage/ocaml-magic-mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9 LICENSE="ISC"
10 SLOT="0/${PV}"
11 KEYWORDS="~amd64"
12 IUSE=""
13
14 RDEPEND="dev-lang/ocaml:="
15 DEPEND="${RDEPEND}
16         dev-ml/jbuilder
17         dev-ml/opam
18 "
19
20 src_install() {
21         opam-installer -i \
22                 --prefix="${ED}/usr" \
23                 --libdir="${D}/$(ocamlc -where)" \
24                 --docdir="${ED}/usr/share/doc/${PF}" \
25                 magic-mime.install || die
26 }