*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ml / ocaml-ipaddr / ocaml-ipaddr-2.8.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit opam
7
8 DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
9 HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
10 SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="dev-ml/sexplib:=
19         dev-ml/ppx_sexp_conv:=
20         dev-ml/ppx_core:=
21         dev-ml/ppx_type_conv:=
22         dev-lang/ocaml:=[ocamlopt?]
23 "
24 DEPEND="${RDEPEND}
25         dev-ml/jbuilder
26         dev-ml/findlib
27         test? ( dev-ml/ounit )
28 "
29
30 src_install() {
31         opam_src_install ipaddr
32 }