dev-ml/labltk: x86 stable wrt bug #708672
[gentoo.git] / dev-ml / ocaml-hashcons / ocaml-hashcons-1.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools findlib
7
8 DESCRIPTION="OCaml hash-consing library"
9 HOMEPAGE="https://github.com/backtracking/ocaml-hashcons"
10 SRC_URI="https://github.com/backtracking/ocaml-hashcons/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1-with-linking-exception"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="+ocamlopt"
16
17 RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
18 DEPEND="${RDEPEND}"
19
20 src_prepare() {
21         eautoreconf
22         sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
23 }
24
25 src_compile() {
26         if use ocamlopt; then
27                 emake opt byte
28         else
29                 emake byte
30         fi
31 }
32
33 src_install() {
34         dodir "$(ocamlfind printconf destdir)/hashcons"
35         emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
36         dodoc README.md CHANGES
37 }