dev-ml/*: drop to ~hppa
[gentoo.git] / dev-ml / ocaml-gettext / ocaml-gettext-0.3.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils autotools
7
8 DESCRIPTION="Provides support for internationalization of OCaml program"
9 HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
10 SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1-with-linking-exception"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND=">=dev-lang/ocaml-3.12.1:=
19         >=dev-ml/ocaml-fileutils-0.4.0:=
20         >=dev-ml/camomile-0.8.3:=
21         sys-devel/gettext
22         dev-ml/camlp4:=
23         "
24 DEPEND="${RDEPEND}
25         doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
26         test? ( dev-ml/ounit )"
27
28 src_prepare() {
29         eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
35                 $(use_enable doc) \
36                 $(use_enable test)
37 }
38
39 src_compile() {
40         emake -j1
41 }
42
43 src_install() {
44         findlib_src_preinst
45         emake -j1 DESTDIR="${D}" \
46                 BINDIR="${ED}/usr/bin" \
47                 PODIR="${ED}/usr/share/locale/" \
48                 DOCDIR="${ED}/usr/share/doc/${PF}" \
49                 MANDIR="${ED}/usr/share/man" \
50                 install
51         dodoc CHANGELOG README THANKS TODO
52 }