dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-ml / ocaml-expat / ocaml-expat-1.1.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib eutils
7
8 IUSE="doc +ocamlopt test"
9 RESTRICT="!test? ( test )"
10
11 DESCRIPTION="OCaml bindings for expat"
12 SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 HOMEPAGE="https://github.com/whitequark/ocaml-expat"
14
15 RDEPEND="dev-libs/expat
16         >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
17
18 DEPEND="${RDEPEND}
19         test? ( dev-ml/ounit )"
20
21 SLOT="0/${PV}"
22 LICENSE="MIT"
23 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
24
25 src_compile() {
26         emake depend
27         emake all
28         if use ocamlopt; then
29                 emake allopt
30         fi
31 }
32
33 src_test() {
34         emake test
35         if use ocamlopt; then
36                 emake testopt
37         fi
38 }
39 src_install() {
40         findlib_src_preinst
41         emake install
42
43         if use doc ; then
44                 dohtml -r doc/html/*
45         fi
46         dodoc README
47 }