dev-ml/camlp5: bump to 7.11
[gentoo.git] / dev-ml / ocaml-dispatch / ocaml-dispatch-0.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Path-based dispatching for client- and server-side applications"
9 HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
10 SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="
19         dev-ml/result:=
20         dev-lang/ocaml:=
21 "
22 RDEPEND="${DEPEND}"
23 DEPEND="${DEPEND}
24         dev-ml/jbuilder
25         dev-ml/opam
26         test? ( dev-ml/ounit )
27 "
28
29 src_compile() {
30         jbuilder build -p dispatch || die
31 }
32
33 oinstall() {
34         opam-installer -i \
35                 --prefix="${ED}/usr" \
36                 --libdir="${D}/$(ocamlc -where)" \
37                 --docdir="${ED}/usr/share/doc/${PF}" \
38                 --mandir="${ED}/usr/share/man" \
39                 ${1}.install || die
40 }
41
42 src_install() {
43         oinstall dispatch
44 }