dev-ml/ocaml-dispatch: Initial import. Ebuild by me.
[gentoo.git] / dev-ml / ocaml-dispatch / ocaml-dispatch-0.3.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_DOCS=1
7 OASIS_BUILD_TESTS=1
8
9 inherit oasis
10
11 DESCRIPTION="Path-based dispatching for client- and server-side applications"
12 HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
13 SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64"
18 IUSE="javascript"
19
20 DEPEND="
21         javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
22         dev-ml/result:=[ocamlopt?]
23 "
24 RDEPEND="${DEPEND}"
25 DEPEND="${DEPEND}
26         test? ( dev-ml/ounit[ocamlopt?] )
27 "
28
29 DOCS=( "README.md" )
30
31 src_configure() {
32         oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
33                 oasis_src_configure
34 }