dev-ml/lablgtk: remove old 2.18.8-r0
[gentoo.git] / dev-ml / ocaml-ctypes / ocaml-ctypes-0.13.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Library for binding to C libraries using pure OCaml"
9 HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
10 SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-lang/ocaml-4.02:=[ocamlopt]
20         virtual/libffi
21         dev-ml/integers:=
22 "
23 DEPEND="${RDEPEND}
24         test? ( dev-ml/ounit dev-ml/lwt )"
25
26 src_compile() {
27         emake -j1
28 }
29
30 src_test() {
31         emake -j1 test
32 }
33
34 src_install() {
35         findlib_src_install
36         dodoc CHANGES.md README.md
37 }