arm64/p.u.m: not keyworded yet
[gentoo.git] / dev-ml / ocaml-ctypes / ocaml-ctypes-0.11.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Library for binding to C libraries using pure OCaml"
9 HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
10 SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64 ~arm ~x86"
15 IUSE="test"
16
17 RDEPEND="
18         >=dev-lang/ocaml-4.02:=[ocamlopt]
19         virtual/libffi
20 "
21 DEPEND="${RDEPEND}
22         test? ( dev-ml/ounit )"
23
24 src_compile() {
25         emake -j1
26 }
27
28 src_test() {
29         emake -j1 test
30 }
31
32 src_install() {
33         findlib_src_install
34         dodoc CHANGES.md README.md
35 }