dev-ml/camlpdf: version bump to 2.3.1
[gentoo.git] / dev-ml / ocaml-ctypes / ocaml-ctypes-0.11.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit findlib
7
8 DESCRIPTION="Library for binding to C libraries using pure OCaml"
9 HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
10 SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 arm x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-lang/ocaml-4.02:=[ocamlopt]
20         virtual/libffi
21 "
22 DEPEND="${RDEPEND}
23         test? ( dev-ml/ounit )"
24
25 src_compile() {
26         emake -j1
27 }
28
29 src_test() {
30         emake -j1 test
31 }
32
33 src_install() {
34         findlib_src_install
35         dodoc CHANGES.md README.md
36 }