dev-ml/llvm-ocaml: Remove 9.0.0*
[gentoo.git] / dev-ml / ocaml-containers / ocaml-containers-1.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 OASIS_BUILD_TESTS=1
7 OASIS_BUILD_DOCS=1
8
9 inherit oasis
10
11 DESCRIPTION="A modular standard library focused on data structures"
12 HOMEPAGE="https://github.com/c-cube/ocaml-containers"
13 SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="BSD-2"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         dev-ml/result:=
23         >=dev-ml/sequence-0.9:=
24 "
25 DEPEND="${RDEPEND} dev-ml/cppo
26         test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
27
28 src_configure() {
29         oasis_configure_opts="
30                 --enable-unix
31                 --disable-bench
32         " oasis_src_configure
33 }